Outbound Instance Setup Emails Failing
Resolved
Sep 08 at 06:13pm PDT
Resolved — The issue affecting outbound instance setup emails has been fully resolved.
All setup emails are now delivering normally.
Impact: Some new customers did not receive their welcome email during this period.
Current Status: Fixed — no further impact expected.
Affected services
Created
Sep 08 at 05:56pm PDT
We’ve identified an issue where outbound instance setup emails are failing to send to new customers. These emails normally contain the initial login details and temporary credentials required to access a newly provisioned Stack Events instance. Because the messages are not being delivered, affected customers are unable to complete their first login or import users without manual intervention.
Impact
- New instance owners do not receive their welcome credentials automatically.
- Customers may experience onboarding delays and require direct support to access their accounts.
- Support workload increases as credentials need to be resent or shared manually.
Current Status
The failure is confirmed to be on the outbound delivery side of our system, not user error. We are actively investigating the root cause (possible mail relay configuration or provider block). In the meantime, credentials are being distributed manually to ensure customers can log in without interruption.
Next Steps
- Continue investigation into mail delivery failure.
- Test outbound mail server and DNS/SMTP settings.
- Provide status updates until resolution.
- Once resolved, re-enable automated setup email delivery and monitor.
Affected services